Contenuto principale

Nell'aprire questa sezione preciso che farò riferimento, nella programmazione, a Micromondi 2.0 (software non più presente nei cataloghi di distribuzione di Campustore http://www.campustore.it/ita/viewpage.aspx?ID=251 sostituito con MicroWorlds Ex) ma il codice, con opportuni adattamenti, si può applicare anche al software free MSWLogo o FMSLogo. La mia preferenza va comunque per Micromondi 2 perchè abbina elementi multimediali più accattivanti che permettono di applicare più facilmente i concetti che via via andrò presentando. Sinceramente non comprendo l'abbandono di Micromondi 2 per MicroWorld Ex dal momento che, a parte piccoli particolari ed una disposizione diversa degli elementi, non è stata introdotta alcuna novità nel linguaggio e nella gestione degli elementi. Tutto ciò che viene presentato quindi può tranquillamente essere applicato, senza alcuna modifica, a MicroWorld Ex mentre per applicarlo a MWSLogo o FMSLogo bisogna evitare le abbreviazioni dei comandi (per il resto funziona tutto correttamente).

Il logo (specie Micromondi) può essere introdotto a scuola fin dalla seconda elementare con piccole esercitazioni, con comandi premodificati dall'insegnante. Si inculca così un concetto fondamentale per l'educazione informatica: il computer lo possiamo programmare per fargli fare ciò che ci serve. Sembra una inezia ma è l'atteggiamento che trasforma un consumatore in un utente (nell'accezione  corretta del termine: che usa lo strmento per rispondere ai propri bisogni).

Personalmente nel corso dell'esperienza scolastica ho sempre cominciato ad introdurre il linguaggio della tartaruga con disegni di linee orizzontali e verticali e rotazioni ad angolo retto.

Un set di comandi minimi per la tartaruga potrebbe essere il seguente:

pulisci
tana
avanti
indietro
giradestra (destra 90)
girasinistra (sinistra 90)
su
giu

Per quanto riguarda i comandi non presenti (giradestra e girasinistra) basta scrivere delle semplici procedure e salvarle come file di base da utilizzare poi con la classe.

Ecco costruiti nuovi comandi utili per bambini di seconda che potranno cominciare a "pasticciare" con la "programmazione" cioè con l'informatica VERA.

Una prima attività potrebbe essere quella di invitarli a costruire una scalinata usando i comandi. Non preoccupiamoci della comprensione dell'utilizzo della consolle dei comandi: ben presto con qualche suggerimento e colpassaparola dei bambini tutti impareranno l'utilizzo base della tastiera per dare i comandi. Senz'altro ci sarà chi riuscirà per primo ad effettuare il disegno richiesto  e lo comunicherà agli altri, ma lo scambio di esperienze farà capire che non tutti hanno fatto la stessa cosa: ci sarà chi ha cominciato dal centro, chi da uno spigolo, chi ha fatto i gradini regolari, chi no, chi li ha fatti lunghi chi alti eccc. E' una buona occasione per affinare la richiesta e chiedere gradini con alzata di ... e pedata di .... Pian piano le procedure si raffineranno fino a permettere un commento generico ed una riflessione. Un altro apprendimento che verrà rinforzato nei bambini è la relatività della destra e della sinistra. Per tutti nasceranno problemi di confusione e dovranno abituarsi a "mettersi nei panni della tartaruga" per individuare la sua destra e la sua sinistra. (Pensate a quanto lavoro viene fatto spesso inutilmente per questo concetto: qui tutto è finalizzato, se si sbaglia lato il disegno viene diverso, la tartaruga ruota dalla parte opposta a dove la si vuole mandare!)

Per un po' di tempo lasceremo gli alunni liberi di costruire le forme come vogliono. Possiamo lanciare dei suggerimenti.... croce, palazzo, muro di mattoni...
Attraverso la scrittura dei comandi i bambini fanno una riflessione profonda sulle linene che costriscono: eguaglianza, rapporto di grandezza, simmetria non saranno termini appresi ma concetti "vissuti" utilizzati nel fare (ma la scuola elementare nelle prime classi non è la scuola del fare?). Tra i vari suggerimenti dati ai bambini ci potrà essere quello di costruire un quadrato e un rettangolo: queste forme sono già conosciute per "uso" da diversi bambini e questa può essere l'occasione per analizzare alcune caratteristiche delle due forme in modo attivo.

Il secondo passo che si può proporre, dopo che gli alunni avranno familiarizzato con i comandi ed avranno disegnato parecchio, è quello della ripetizione dei comandi introducendo il comando "ripeti". Per raggiungere questo risultato è utile procedere alla riflessione ed alla scrittura dei comandi su carta da trascrivere poi su pc: poter visualizzare bene i comandi potrà portare qualche alunno alla fatidica osservazione "ci sono dei comandi che si ripetono". Attraverso l'analisi attenta si arriverà ad identificare il "blocco" dei comandi che si ripete. A questo punto si potranno riprendere i disegni già fatti e cominciare a vedere se ci sono "moduli" che si possono ripetere. Ad esempio per la prima scalinata:

giu
ripeti 5 [ avanti 20 giradestra avanti 40 girasinistra]

Non ci sono moduli ripetuti per la seconda mentre per la terza scalinata avremo

giu
ripeti 4 [ avanti 40 giradestra avanti 40 girasinistra] 

per il nostro quadrato

giu
ripeti 4 [ avanti 100 giradestra]

per il nostro rettangolo

giu
ripeti 2 [ avanti 100 giradestra avanti 180 giradestra]

Un altro apprendimento interessante e formativo è la scrittura delle procedure. Messo sotto forma di similitudine con la scuola può essere divertente: anche la tartaruga impara, come noi ha una "aula" dove studia (la pagina delle procedure), è una brava tartaruga perchè non dimentica ciò che impara!

Potremmo procedere quindi a scrivere la procedura del "quadrato" per insegnare alla tartaruga a fare un quadrato e a poter riutilizzare il comando appreso.

per quadrato
giu
ripeti 4 [ avanti 100 giradestra]
fine

Facendo delle prove di utilizzo ed incoraggiando i più fantasiosi si potrebbe arrivare alla costruzione di qualcosa di simile:

Con comandi da trasformare in procedura (che potremmo chiamare "quadri"
per quadri
tana
pulisci
su
girasinistra
avanti 300
giradestra
indietro 150
ripeti 4 [ giu quadrato su giradestra avanti 150 girasinistra]
su
avanti 150
ripeti 4 [ girasinistra avanti 150 giradestra giu quadrato su]
fine

Il tutto potrebbe essere concluso con la colorazione utilizzando la consolle della pittura - secchiello vernice (arrivare ad una conclusione gratificante è sempre un ottimo rinforzo per non vanificare il percorso fatto).


Dopo aver lavorato con queste procedure base si deve passare alla presentazione dell'angolo di rotazione e della sua misura in gradi. La misurazione sembra essere uno scoglio arduo ma tutto dipende da come è stato affrontato il discorso scientifico su un elemento basilare: la convenzione. Se questo concetto è stato sviluppato nei primi due anni (prima e seconda elementare) la presentazione dell'angolo, con il valido aiuto della tartaruga, è una cosa fattibile e comprensibile.

I primi esercizi dovrebbero essere liberi spiegando ai bambini che in effetti esistono due comandi per la rotazione (destra e sinistra) che richiedono un argomento: questo argomento è un numero che misura di quanto ruota la tartaruga. L'invito potrebbe essere proviamo a ruotare la tartaruga usando la sintassi destra n e sinistra n (n sta per numero, solo più avanti si spiegherà che si chiamano gradi), e a mandarla avanti du una lunghezza compresa tra 50 e 100. Un esercizio che ne potrebbe risultare potrebbe essere simile a questo:

Nel "pasticciare" verranno fuori considerazioni che, opportunamente guidate, porteranno gli alunni a scoprire che la rotazione massima di una tartaruga è 359 dopodichè torna nella direzione in cui si trovava quindi scrivendo de 360 è come scrivere de 0. Ci potrebbero arrivare anche partendo dalla considerazione che con de 180 le tartarughe si girano all'indietro... Fatto sta che scoprire gli angoli in questo modo è quanto di più normale ci possa essere con la differenza che gli alunni, rispetto agli apprendimenti tradizionali, in questo modo stanno scoprendo e costruendo i propri concetti geometrici. 

Una volta giunti a questo punto si sostituiranno i comandi di base giradestra e girasinistra con quelli più efficienti di destra n e sinistra n e si potrà partire con lo studio della geometria piana: la geometria della tartaruga.

Ora si potranno stimolare gli alunni a costruire procedure su cui intervenire: partiamo dal quadrato. Invitiamo a scrivere le  procedure per costruire quadrati di diversa grandezza.

Queste procedure porteranno gli alunni, se stimolati, a fare le seguenti considerazioni:

  1. per fare quadrati grandi o piccoli basta variare la misura del lato, l'angolo rimane sempre uguale
  2. se si cambia la misura dell'angolo la figura non si "chiude" correttamente
  3. la tartaruga ruota sull'angolo "supplementare" (l'angolo complementare ad un altro per formare assieme 180 gradi)

Quest'ultima considerazione è di fondamentale importanza per la "geometria della tartaruga", se non dovesse venir fuori è bene stimolare la conversazione perchè emerga.

Esempi di "lavori" che si possono fare sfruttando la procedura per il quadrato:

E pian piano avverrà la scoperta di quante forme complesse è possibile costruire sfruttando una semplice figura fissa o variabile in grandezza. Quella poi dei disegni ottenibili sfruttando la rotazione di una figura potrà essere il passo seguente con le riflessioni: quante figure devo ripetere? Di quanti gradi devo ruotare ogni volta? La figura è completa o ho saltato qualche quadrato? (L'utilità di una procedura che lo faccia in automatico senza saltare nessun passaggio nasce spontanea).

 
La parte riquadrata in rosso è il quadrato se quindi è stata costruita la procedura per il quadrato la riga diverrà più semplicemente "ripeti 12 [ quadrato de 30]"


 

Quando si costruisce un poligono, attraverso disegni, bisogna far comprendere un concetto fondamentele legato alla rotazione e al cambio di direzione della tartaruga che disegna. Il quadrato per il fatto di possedere angolo interno ed angolo supplementare uguale si presta bene al ragionamento.
Far notare che si può fare la somma degli angoli interni e quella degli angoli esterni.
Il ragionamento più importante da far fare è il seguente: la tartaruga, nel disegnare una figura chiusa e tornare nella sua posizione di partenza, dovrà per forza fare complessivamente una rotazione di 360°; questo per qualsiasi figura.

In un poligono regolare, quindi, visto che la rotazione complessiva deve essere di 360°, per calcolare la rotazione ad ogni cambio di direzione per disegnare un lato, lo calcoleremo con: 360 / numero_lati. Per questo la figura del quadrato, oltre che con la procedura "ripeti 4 [ avanti 100 destra 90]", si potrà ottenere anche con la procedura "ripeti 4 [ avanti 100 destra 360 / 4 ]".

Il secondo modo ci permetterà, cambiando il numero della ripetizione, e parallelamente il numero della divisione, di costruire qualsiasi poligono con n lati ("ripeti n [ avanti 100 destra 360 / n ]" dove n rappresenta il numero dei lati del poligono regolare.

ma la procedura potrà essere similmente alla precedente "ripeti 3 [ avanti 100 destra 360 / 3 ]" ed avrà la stessa efficacia della precedenza ma guadagna in efficienza perchè è più generica ed applicabile a qualsiasi poligono.

Per il pentagono "ripeti 5 [ avanti 100 destra 360 / 5 ]"

Per l'esagono "ripeti 6 [ avanti 100 destra 360 / 6 ]"

Per il decagono "ripeti 10 [ avanti 80 destra 360 / 10 ]"

Per un poligono di 20 lati "ripeti 20 [ avanti 60 destra 360 / 20 ]"

In un baleno i bambini capiranno che aumentando il numero dei lati e diminuendo la misura del lato ( altrimenti la figura non entra nell'area grafica) otterranno qualcosa del genere:

Toh! un cerchio con "ripeti 360 [ avanti 2  destra 360 / 360 ]". Quindi potremo definire il cerchio come quella figura che la tartaruga disegna quando avanzando cambia continuamente direzione, cioè la definizione geometrica di una linea curva.

 


Alcuni poligoni regolari si prestano allo studio della modularità.

Immaginiamo ora di aver preparato una procedura per il disegno di un triangolo equilatero con:

per tria
ripeti 3 [av 50 de 360 / 3]
fine

 potremo attraverso delle prove costruire qualcosa di simile e raccogliendo le varie ripetizioni effettuate verrebbe fuori questa procedura per ottenerla: "ripeti 3 [ ripeti 3 [ tria av 50] de 120]"
Variando o meglio integrando, se  la procedura precedente la ripetiamo per 6 volte facendo ruotare ogni volta di 60 gradi la tartaruga cioè "ripeti 6 [ripeti 3 [ ripeti 3 [ tria av 50] de 120] de 60]" otterremo il modulo in figura.

Sfruttando la modularità possiamo scrivere delle procedure che campongano per esempio un reticolo di questo tipo:


per fare questo non esistono delle procedure univoche ma le stesse si possono costruire utilizzando prima i comandi interattivi e poi raggruppando i comandi utilizzati in procedure: questo potrebbe essere un modo ripeti 7[ripeti 7 [ tria av 50] de 60 av 50 de 120 av 7 * 50 de 180 ripeti 7 [ tria av 50] de 120 av 50 de 60 ripeti 7 [ tria av 50] de 120 av 50 de 60 de 120 av 50 si 120]

per questo disegno modulare potremmo averne uno così: ripeti 3 [ripeti 2[ripeti 7 [ tria av 50] de 120 av 50 de 60] av 50 * 7 de 120 av 50

 


Provando in vario modo ci si accorgerà che che il pentagono non si presta per disegni a moduli ripetuti mentre si può utilizzare efficacemente l'esagono.
Col pentagono possiamo costruire figure particolari sfruttando la ripetizione e un altro poligono regolare centrale.

 

utilizzando rispettivamente le seguenti procedure:
ripeti 5 [penta av 40 si 360 / 5]
ripeti 6 [penta av 40 si 360 / 6]
ripeti 8 [penta av 40 si 360 / 8]
ripeti 10 [penta av 40 si 360 / 10]

Curioso è invece constatare come semplicemente variando il verso di rotazione da sinistra a destra nell'ultima procedura  ripeti 10 [penta av 40 de 360 / 10] otteniamo l'ultimo disegno (stelle inscritte in un decagono).

Con l'esagono invece ecco cosa possiamo ottenere con la modularità:

Dato per scontato di aver costruito e salvato una procedura per fare un esagono da 30 di lato chiamata "esa", potremo avere dei moduli che, partendo da un semplice "ripeti 3 [ esa de 120 ]" che fa disegnare la prima immagine composta da tre esagoni, arrivi via via espandendo e nidificando le ripetizioni, all'ultima immagine:
ripeti 6 [esa  av 30 si 60] per la seconda immagine e
ripeti 6[ripeti 6 [esa  av 30 si 60] av 30 de 60] per la terza immagine.

Per coprire una intera area con "mattonelle esagonali" potremmo attivare una procedura del genere:
ripeti 4[ ripeti 10 [ esa de 120 av 30 si 60 av 30 si 60 ] de 120 av 30 de 60 ripeti 10 [ esa de 120 av 30 si 60 av 30 si 60 ] av 30 de 60 av 30 si 60 av 30 de 180 ]
ed ecco il risultato (la tartaruga alla partenza va posizionata in alto a sinistra dove è mostrata nell'immagine).

Con l'ottagono, dando per scontato di aver creato la procedura "otta" per disegnare un ottagono con lato di 30 potremmo operare con queste procedure:

ripeti 4 [otta de 135 av 30 si 45] per il primo disegno
ripeti 8[otta de 135] per il secondo disegno
Per ottenere invece la copertura di un'area con figure ottagonali potremmo usare una procedura di questo tipo

ripeti 8 [ ripeti 4 [ otta su av 30 de 45 av 30 si 90 av 30 de 45 giu] ripeti 4 [ su si 45 in 30 de 90 in 30 si 45 in 30 ] si 45 in 30 si 45 in 30 si 45 in 30 de 135 giu ]

 


Abbiamo già visto che se utilizziamo la procedura generica per la creazione di un poligono regolare " ripeti nvolte [ avanti misuralato de 360 / nvolte ]" e se poniamo la ripetizione a 360 o un suo multiplo e la misura lato molto piccola, originiamo un cerchio.
E' evidente che, se vogliamo disegnare un arco (linea curva) dovremo limitare la ripetizione in modo che la tartaruga non compia il giro completo, come negli esempi:

 

ripeti 360 [ av 2 de 360 / 360 ] per originare il cerchio
ripeti 180 [ av 2 de 360 / 360 ] per originare il semicerchio
ripeti 100 [ av 2 de 360 / 360 ] per originare l'arco con l'angolo al centro di 100°

 ripeti 180 [ av 2 de 360 / 360 ] ripeti 120 [ av 1 si 360 / 360 ] per generare la doppia curva (cambia il verso di rotazione e la lunghezza dell'avanzamento)

Se si vuole ottenere un cerchio relativo ad un raggio si andrà a sfruttare la formula della circonferenza: C=r*6.28. Per stabilire l'avanzamento della tartaruga ad ogni rotazione di un grado dovrà corrispondere l'avanzamento di un trecentosessantesimo della lunghezza della circonferenza. Se si vuol disegnare un cerchio con raggio 80 avremo:
av 80 de 90 ripeti 360 [ av 80 * 6.28 / 360 de 360 / 360]
mentre per disegnare un settore circolare con l'angolo al centro di 60° seguiremo questa procedura...
av 80 de 90 ripeti 60 [ av 80 * 6.28 / 360 de 360 / 360] tana de 60 av 80 de 90 ripeti 300 [ av 80 * 6.28 / 360 de 360 / 360]
(In questo abbiamo disegnato anche la parte complementare riportando la tartaruga in tana e disegnando con la stessa modalità il restante settore.)

Una osservazione graficamente accattivante è il comportamento del cerchio nella modularità e nella ripetizione: eccone alcuni esempi tenendo in considerazione che il comando "cerchio" chiama una procedura di costruzione del cerchio che utilizza un avanzamento di 1.5.

Ecco le rispettive procedure per queste figure:
ripeti 4 [ cerchio de 360 / 4]
ripeti 12 [ cerchio de 360 / 12 ]
ripeti 12 [ cerchio de 360 / 12  av 20]

Continua....